[gelöst] wie bekomme ich diese meldung weg?

  • Ich glaube, mal was gelesen zu haben mit xBue Kontakten welche aus irgendeinem Grund die DBSig Library laden. Außerdem, wenn es von der Library selbst kommt reicht, wenn seit Spielstart irgendwo irgendwas mal xBue geladen hat, ist ziemlich dämlich gemacht. Jedenfalls wenn die Meldung auch auftaucht, wenn du das Spiel komplett neu startest und dann als allererstes deine Strecke lädtst, dann scheint irgendwas auf deiner Strecke DBSig zu laden. Das müsste dich ziemlich leicht herausfinden lassen, indem du die Abhängigkeiten deiner Strecke anzeigen lässt im CM und dann oben den Filter auswählst "Dependencies Include" und dort die Kuid der DBSig Library einfügst.


    Probiere unbedingt verschiedene Versionsnummern der DBSig Library durch hier, wenn dir nicht direkt etwas angezeigt wird.



    Greets, Mika

    Strecken- und Szenariobauer, Repainter, Skripter, Objektbauer, Moderator und Mädchen für alles...


    "It's always more fun to share with everyone" -Jack Johnson

  • Vielen Dank für Eure schnellen Antworten.

    Ich habe jetzt die Version 12 der Bibliothek installiert.

    Leider wird die Meldung immer noch angezeigt.


    Ich habe mir in den Abhängigkeiten alle Regeln (Rule)

    anzeigen lassen, welche auf dieser Anlage verwendet

    werden. Es sind folgende KUID/Objekte.

    Code
    <kuid:401543:3203>       Interlocking Tower Path Selection UI
    <kuid2:60850:89003:1>    Clean Up Derailed Trains
    <kuid:401543:1180>       ConsistDataHandler rule
    <kuid:401543:1184>       QuickDrive rule
    <kuid:-3:10057>          Driver Command
    <kuid:-16:2025>          Driver Setup
    <kuid:-3:10206>         Display Custom HUD

    Zudem verwende ich (nicht bewusst) die XBue oder

    ähnliche Objekte auf dieser Strecke, welche zu einem

    Großteil aus polnischen Objekten gebaut wurde/wird.


    Mika

    Das Setzen des Filters "Dependencies Include" erschließt

    sich mir (nicht nur) in diesem Zusammenhang nicht. Ich

    bekomme keine Veränderung in er Auswahl der Objekte.

    Hier entsteht eine neue Signatur.

    Der Betrieb läuft trotzdem weiter.

  • Klar doch! Ich habe alles richtig gemacht. *

    • Objekt filtern
    • Objektversionen anzeigen lassen
    • Objekt in der Version 12 explizite installieren
    • Objekt in der Version 13 löschen * ***

    Multitasking kann ich *

    Trainzen und nebenbei Essen kochen *


    Mal was anderes.

    Wie teuer ist eigentlich eine Brandversicherung für Mietwohnungen?

    Frage selbstverständlich für einen Nachbarn. **


    Hier entsteht eine neue Signatur.

    Der Betrieb läuft trotzdem weiter.

  • ujb1

    Changed the title of the thread from “wie bekomme ich diese meldung weg?” to “[gelöst] wie bekomme ich diese meldung weg?”.
  • Eure Lösung funktionierte auch bei mir nicht auf Anhieb. Hab dann die Version 12 auf 14 geändert, die 13 somit als obsolet erklärt, dann war die Fehlermeldung endlich weg.

    Wer das auch so machen will:

    Es reicht nicht die 12 in 14 zu ändern und zu speichern. Das geht nicht.

    12 öffnen, in 14 ändern, Editing-Ordner neu installieren, 14 übernehmen, 12 zurücksetzen

    Die gleiche Verfahrensweise empfiehlt sich auch für Scara-Signale Vers.5+6 (5 in 7)

    Irgendwie merkt sich Trainz, das ehemalige Vorhandensein einer höhergestellten KUID. Nur Löschen einer neueren Version funktioniert im Bezug auf die Aktivierung einer älteren (obsoleten) Version nicht. Was mal als obsolet gekennzeichnet war, lässt sich nicht mehr richtig funktional in den Vordergrund bringen.

    Grund: Nach einem Datenbankabsturz habe ich aus Zeitgründen die Datenbankreparatur abgebrochen und eine ältere gesicherte TDX Datei eingespielt. Als ich dann Teile installieren wollte, die im Prinzip schon vorhanden waren, gabs logischerweise einen Datenbankzugriffsfehler. Deswegen hab ich diese Teile in kuid2 "höhergesetzt". Später nach einer Datenbankreparatur wollte ich meine künstliche Doppelbelegung durch Löschen der höhergestellten Kuid bereinigen. Diese Teile wurden in der Originalversion als Abhängigkeiten nicht mehr geführt. Die gelöschte "Scheinversion" wurde mit Fragezeichen in der Datenbank weitergeführt.

    LG Frank

  • Hallo Jürgen

    In diesem Fall, habe ich das garnicht probiert, weil ich die 12 schon hatte. Ich hatte kurz zuvor, deine Methode zum Ersatz der Scara-Signale verwendet. Das hat insofern nicht funktioniert, daß die betreffenden Maps diese Signale nicht mehr als Abhängigkeit akzeptierten und sie als Fehlteile auswiesen. Daher mein jetziges Vorgehen.

    Hattest du vor der 13, die 12 noch nicht? - Vieleicht macht das einen Unterschied.

    LG Frank

  • Okay ich hab mich jetzt mal selbst auf die Suche gemacht... Die "bösen" Objekte sind, überraschung, ausschließlich vom Autor callavsg. Es handelt sich um

    (<kuid2:400048:100364:6>,<kuid2:400048:100338:6>,<kuid2:400048:100352:6>,<kuid2:400048:100365:6>,<kuid2:400048:100391:7>)

    Wenn ihr irgendwas davon verbaut wird unweigerlich die DBSig Library geladen und diese Meldung erscheint.



    Greets, Mika

    Strecken- und Szenariobauer, Repainter, Skripter, Objektbauer, Moderator und Mädchen für alles...


    "It's always more fun to share with everyone" -Jack Johnson

  • Moin!

    Ich möchte dazu auch noch sagen: Die xBUe-Systeme sind auch ohne die Verwendung der Objekte von callavsg aufbaubar. Dazu einfach die übrigen xBUe-Kontakte nutzen.


    Der hauptsächliche Vorteil bei der Nutzung von callavsgs Objekten lag in der Möglichkeit der Steuerung der BÜs über Fahrerkommandos. Dafür wiederum war eine "zentrale Sammelstelle" für alle Öffnungs- und Schließbefehle eines BÜs nötig woraus dann die xBUe-Regel und die globalen Kontakte resultieren.

    Darauf muss man dann natürlich leider verzichten.

  • Hallo,


    Nun, ich habe keines der Objekte verbaut, bzw. nicht mehr. Habe dennoch die Meldung des DBsig. :/

  • Habe dennoch die Meldung des DBsig.

    Ja, leider. Auch bei mir. Die Anzeige des installierten Materials im CM von T:ane dauerte heute morgen 42 Minuten. Da ich bei der SSD kein Defrag machen kann, habe ich eine Datenbankreparatur laufen lassen. Ziel ereicht, Ladezeit ist erheblich kürzer. Trainz gestartet. SL gestartet..... Alle vorangegangenen Aktionen umsonst, Meldung ist wieder da. ???

    MfG Frank


    Da noch kein Folgepost existiert, will ich noch etwas ergänzen.

    Ich hatte wegen dem gesamten Signalproblem eine Neuinstallation beabsichtigt. Es ist ja nicht nur das DBsig-Problem. Auch die ÖBB-Signale der Brennerbahn arbeiten im SP4 fehlerhaft. Mein T:ane hätte dann wieder die 4.2. Würde das etwas mehr Funktionalität bringen? Oder nur SP3 ohne SP4?

  • Die, die nach Entfernung der betroffenen Objekte von der Strecke und der Session (beides die Abhängigkeiten im CM überprüft?) noch die Meldung haben...


    Spiel einmal komplett neu gestartet? Also alle Fenster zu, 10 Sec warten, wieder öffnen und dann DIREKT auf die eigene Strecke gehen?
    Libraries bleiben nämlich erhalten wenn sie vorher schon von irgendeinem Objekt geladen wurden.


    Wenn das nicht hilft, Spielneustart, Datenbankreparatur, Spielneustart und danach direkt auf die Strecke, funktioniert das?

    Ich hab auch schon von der Skripttechnischen Seite reingeschaut ob man den Browser nicht einfach fernsteuern kann sodass ein anderes Skript den einfach zu macht damit Ruhe im Karton ist, aber... Es wurde gründlich darauf geachtet dass weder User noch andere Skripte auf dieses Fenster zugreifen können und es also immer in der Ecke hängt sobald irgendwas auf die Idee kommt, die Library zu laden.



    Greets, Mika

    Strecken- und Szenariobauer, Repainter, Skripter, Objektbauer, Moderator und Mädchen für alles...


    "It's always more fun to share with everyone" -Jack Johnson