Den Talent 2 für TS2009/10

  • Hallo liebe Trainz-Community,


    ich habe folgende Frage doch davor etwas Hintergrund dazu.

    Vor zwei Wochen habe ich angefangen den Talent 2 für TS2009 zum Laufen zu bringen. Bei den Abhängigkeiten konnte ich, bis auf den Führerstand, alles mit bisschen Tricksen im Content Manager fehlerfrei machen. Ab dem Punkt wo indizierte Meshes nicht laden können, komme ich nicht wirklich weiter. Einige Meshes wurden bei mir mit .lm(kleines L) angezeigt während in der .config .im stand. Das .im habe ich in den Dateinamen übernommen ich komme allerdings trotzdem nicht weiter. Könnte jemand die Talent 2 Züge für TS2010/09 hochladen oder mir sagen wie ich die in TS2010/09 zum Laufen bekomme, dass wäre sehr hilfreich.


    Mit freundlichen Grüßen,

    Willo

  • Das Problem ist, dass die aktuelle (T:ANE+) Version des Zuges Bautechniken verwenden, die es in vorigen Trainz-Versionen schlichtweg nicht gab. Da kannst du prinzipiell nicht viel dran rütteln.
    Es gibt irgendwo eventuell noch die erste Betaversion des Zuges welche für Trainz 12 war, dort wurden diese Sachen noch nicht eingesetzt und es war irgendwie möglich diese Fahrzeuge in PTP2 zum Laufen zu bringen. Zumindest erinnere ich mich, dass simufan davon im TrainzDepot noch einige Bilder gezeigt hat...




    Greets, Mika

    Strecken- und Szenariobauer, Repainter, Skripter, Objektbauer, Moderator und Mädchen für alles...


    "It's always more fun to share with everyone" -Jack Johnson

  • Guten Abend,


    ich habe mir die Vorabversion heruntergeladen und hab die Fehlerursache im Führerstand gefunden:

    Fehler: Textur '442-fstand-pult-alpha-442-fstand-pult-alpha.texture' fehlt oder kann nicht geladen werden für Mesh 'main.im'.

    Fehler: Textur 'mfd/442-fstand-pult-alpha.texture' fehlt oder kann nicht geladen werden für Mesh 'mfd\needleamps.im'.




    Jedoch weiß ich nicht wie man sie beheben kann, denn bei simufan scheints ja zu funktionieren.

    Ich bedanke mich für jegliche Hilfe und wünsche euch einen schönen Abend.

  • Ist in dem Ordner eine "442-fstand-pult-alpha.texture" vorhanden? (Ich frage, da (zu mindestens der TRS19) Probleme beim "Umwandeln?" zur .texture.txe sowie .texture.png? hat).

    Meistens hat die .texture-Datei ein weißes Icon.

  • Ja, es ist eine ''442-fstand-pult-alpha.texture'' vorhanden

    Du kannst versuchen, die Fehler verursachenden Dateien mithilfe des "Images2TGA" Programm von N3VGames? zu "entpacken."


    Wichtig:

    Du musst die alten Dateien (.texture, nur die .texture-Dateien), bevor du die Objekte wieder einbindest, entweder löschen oder bis zum sicheren Test sichern in einem anderen Ordner wie im Dokumente-Ordner.

  • Du kannst versuchen, die Fehler verursachenden Dateien mithilfe des "Images2TGA" Programm von N3VGames? zu "entpacken."


    Wichtig:

    Du musst die alten Dateien (.texture, nur die .texture-Dateien), bevor du die Objekte wieder einbindest, entweder löschen oder bis zum sicheren Test sichern in einem anderen Ordner wie im Dokumente-Ordner.

    Habs versucht, dass bringt ebenfalls nicht. Ich würde mich evtl. bei simufan melden wie er den Talent zum laufen bekommen hat. Am sonsten lass ich das jetzt mal so stehen da ich befürchte das man nicht mehr viel machen kann(es sei denn jemand anderes kann es auf TS2010 downgraden, aber nur wenn es geht und Zeit dafür besteht, sowie ich es ja sehe wird fleißig an Projekten gearbeitet). Sollte es doch Lösungen geben, nehme ich diese gerne in Empfang. Ich bedanke mich für jegliche Hilfe.


    Mfg

    Willo

  • Am Besten ihr verschiebt diesen Thread in Eure Konversation. Die schlichtweg falschen Mutmaßungen sind unerträglich. Hier werden Falschinformationen verbreitet.


    Mal was grundsätzliches zu diesem Thema:

    In der Meshdatei liegen die Informationen der dazugehörigen Bilddateien.


    Eine Bilddatei als Texture hat die Dateiendung *.texture und nicht *.texture.txt. Mit dem Prog "Images2TGA" lässt sich aus einer *.texture Datei eine *,tga Datei + der dazugehörigen Steuerdatei *.texture.txt ableiten.


    - Error: Bilddatei lässt sich nicht öffnen-

    Die Fehlermeldung ist nicht richtig übersetzt. Das heißt: Der Eintrag der Steuerdatei (*.texture.txt) in der Meshdatei (*.im oder *.pm) stimmt nicht überein.( In den seltesten Fällen ist tatsächlich die TGA-Datei defekt) Die *.texture.txt-Datei muß 100% übereinstimmen mit dem Eintrag des Meshes. Der Eintrag innerhalb der *.texture.txt Steuerdatei ist frei wählbar, so wie die zugehörige Bilddatei heißt (xyz.tga od. jpg od. bmp)

    Wichtig!- der CCP in den älteren Trainzversionen prüft lediglich den Zusammenhang der Bilddateien mit den zugehörigen Steuerdateien, es ist dabei NICHT möglich einen fehlerhaften Meshbezug zu erkennen. (Daher kommt die falsche Fehlermeldung)


    Entweder kann man mit einem Mesheditor den Zusammenhang vergleichen oder man benutzt das PEV Tool "Pm2Im". Dort kann man nicht nur pm's in Im's wandeln, sondern auch fehlerhafte Bilddateizuordnungen reparieren. Dazu muß man dieses Tool öffnen und in den Einstellungen "IM Datei öffnen" auswählen (das ist standardmäßig deaktiviert). Jetzt die betroffene IM Datei einlesen. Wenn möglich, konvertiert und speichert das Prog selbstständig. Wenn eine solche Automatikreparatur auf Grund weiterer Meshfehler fehlschlägt, so wird im Programmfenster des Tools diese Fehlermeldung angezeigt. Da gäbe es noch weitere Lösungsansätze.

    MfG Frank

  • Also ich hab es eigentlich fast geschafft es gibt nur noch einen Fehler:

    Fehler: Unable to link compiled script class.

    Ich habe mir den Lexikon-Eintrag durchgelesen aber es funktioniert nicht. Kann man da noch was machen?

    MfG

  • Es ist schon ziemlich lange her, als ich diesen Umbau machte.

    Einträge in der Config.txt des Steuerwagens:

    script "talent442.gs"

    class "CTriebwagen"

    Vorraussetzung ist natürlich das Vorhandensein dieser GS-Datei im Hauptordner (ca.3kb)

    Das Script funktioniert NICHT im reinen PTP2. Nur TS2009/10/12/+

    Im PTP2 muß ein Script von einem ähnlichen PTP2-Fahrzeug eingesetzt werden.

    MfG Frank

  • Und was muss ich im Führerstand ersetzen? Weil da ist nämlich genau das selbe Problem.