Was ist das?

  • Beim Umbau des Bahnhofs Mayen Ost auf der Eifelquerbahn, wollte ich die Bekohlungsanlage etwas verschieben. Dabei bleibt ein animierter "Schaufler" stehen. Was ist das? Ich kann den nicht greifen bzw. verändern, löschen oder verschieben. (Der gehört wohl zum Mainboard) Wer kann helfen?

    LG Frank

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    • Official Post

    Ist etwas schwer eine Ferndiagnose zu machen,

    Option 1: Ein Layer Problem?

    Option 2: Alternativ kann sein, dass der Anklickpunkt nicht auf der Figur sondern irgendwo anders ist.

    Option 3: Diese Figur gehört zu einem anderen Objekt und dann siehe 1+2


    Vielleicht findest du den Mensch und kannst den neu platzieren und verschieben, würde einiges ausschließen ?

  • Vielleicht findest du den Mensch und kannst den neu platzieren und verschieben, würde einiges ausschließen

    Das ist ja genau das Problem! Ich finde den nirgends. Ich weiß nicht welches Objekt es ist.

    Der stand ja ursprünglich in dem animierten Kohlebansen. Den habe ich neu platziert. Der bringt aber den Schaufler nicht mit.


    EDIT: Erledigt, EW-Kohlenschipper-Grundplatte+Mesh, erst gelöscht, dann fehlende Abh. gelöscht, neu von DLS installiert, neu platziert.

    Krönung: Nach dem Neusetzen lässt sich das Objekt wieder nicht greifen bzw. verändern......

    :frowning_face:

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    Edited once, last by buderberlin ().

  • Ich wollte den jetzt noch etwas drehen. Geht nicht. Nicht greifbar.

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

  • Ich stoße wiedereinmal an die Grenzen meines Wissens. Unter dem Motto: Reparieren durch Wegnehmen/Löschen.....

    Kann mir jemand diesen Fehler erklären, bzw die Stelle nennen, an der dieser Fehler auftritt.

    Das ist der kaputte Rest in TRS19 des SLW Gesamtpaketes.

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

  • Danke Peter, jetzt geht alles.

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch


  • Ich stoße wiedereinmal an die Grenzen meines Wissens. Unter dem Motto: Reparieren durch Wegnehmen/Löschen.....

    Kann mir jemand diesen Fehler erklären, bzw die Stelle nennen, an der dieser Fehler auftritt.

    Das ist der kaputte Rest in TRS19 des SLW Gesamtpaketes.


    Code



  • Mal ungeachtet der richtigen Lösung von Peter, hätte mir gereicht zu wissen, daß es sich um einen Fehler in einem Effekt-Eintrag handelt. Ich hätte in diesem Fall:

    Reparieren durch Wegnehmen/Löschen.....

    angewendet. "Smoke17"+"Smoke29" hätte ich entfernt. Damit wäre die Lok fahrbar, zwar unvollständig in ihren Effekten, aber sie würde in Trainz fehlerfrei sein.


    Wenn ich eine solche entsprechende Lok in meinen engeren Auswahlkreis aufnehmen würde, würde ich sowieso den Orig. Dampfausstoß verändern. Dann würde ich den Dampf-Effekt-Container einer für meine Ansprüche genügenden anderen Lok übertragen. Eventuell Attachementpunkte anpassen, auch wenn es nicht der Realität entspricht. Damit wäre der (wegnehmen/löschen) Fehler dann auch weg.


    In meiner Vorstellung muß eine Dampflok "Sch, Sch, Sch, ...." machen (in Ton und Bild), das ist wichtig. :winking_face: :smiling_face_with_sunglasses: :grinning_squinting_face:

    (Und sie muß den langnachhallenden Hornsound der BR81 von Gerd Traue haben :sparkling_heart: )


    PS: Ich bitte diesen übertriebenen Beitrag nicht ganz ernst zu nehmen.....

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    Edited 6 times, last by buderberlin ().

  • Die Smoke-Einträge müssen immer fortlaufend nummeriert sein. Wird ein Eintrag gelöscht, so müssen die folgenden EInträge neu nummeriert werden. Das kann jedoch zu Problemen mit geskripteten Smoke-Effekten führen, da diese durch ihre Nummer angesprochen werden.


    Bei vielen (älteren und nicht Full-HD) Loks von SLW funktionieren Sound und Smoke nicht richtig (ab TRS2009 bzw. TC3), da noch alte Enginesounds und Enginespecs verwendet werden.


    Peter

  • Peter, so detailliert wollte ich jetzt nicht auf dieses Thema eingehen. So wie du es beschreibst, habe ich es auch gemacht. Alle Abhängigkeiten sind den neuen Trainzversionen angepasst. Zahlenreihungen beginnen bei "0" und sollten fortlaufend eingetragen sein, nicht nur in Effekt-Containern.


    EDIT: Der tatsächliche Effektablauf hat doch nur bedingt mit der vom Hersteller N3V vorgegebenen Syntax in der Config.txt zu tun. Wichtig ist doch erstmal die Möglichkeit betreffende fehlerhafte Objekte im Spiel aufrufbar/anzeigbar zu machen. Danach kann man sich um die Effektabläufe kümmern.

    Wenn ich Fehler finde, die ich nicht zuordnen kann, muß ich event. betroffene Effekte rausnehmen, um eine Basis zu schaffen. Bei fehlenden Grafikdateien z.B. lösche ich fehlende Verknüpfungen mit dem IM-Editor im Mesh. Ist das entsprechende Objekt dann fehlerfrei, kann es angezeigt werden. Dabei hat die Trainz-Fehlerfreiheit nichts mit der möglich unvollständigen Anzeige des Objekts zu tun. Wenn die Bilddatei z.B. Dach.jpg fehlt, deren fehlerhafte Verknüpfung ich gelöscht habe, um das Objekt überhaupt sichtbar zu machen, kann es passieren, das das Dach, die hellgraue Meshgrundfarbe hat. Es fehlt vieleicht eine Ziegel- oder Dachschindeltextur. Die könnte ich dann aus einem ähnlichen Haus reinkopieren und wieder neu verknüpfen. - Aber mit dem ursprünglich garnicht angezeigten fehlerhaften Objekt, kann ich eine solche Reparatur garnicht durchführen. (Dach.jpg ist hier eher witzig, es könnten auch "ausländische" Bildnamen sein, die man nicht logisch ermitteln kann)

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    Edited 2 times, last by buderberlin ().

  • Irgendwie komme ich mir verarscht vor. Die beiden Trams (T57+GT4 von ConnyXY) zeigen ein merkwürdiges KI-Verhalten. Auch der Austausch des Motors von den anderen Altbautrams brachte keine Änderung.

    Die Vmax liegt bei 50kmh (Faktor 14).

    Was das Bild (noch) nicht zeigt: Das rote Signal in 90m wird ohne Bremsen überfahren. Dann fährt der Zug auf den Vorherfahrenden auf. Dieses entstandene Gesamtgespann blockiert dann 2 Minuten die gesamte Strecke nach dem Signalüberfahrer.

    An dieser Stelle bin ich ratlos.

    Warum werden die Geschwindigkeitsmarker nur von diesen Zugtypen nicht beachtet?

    Warum fährt der Zug schneller als die Vmax des Motors ist?

    Warum werden Signale ignoriert? (Das Signal ist schon eine ganze Weile rot - nicht plötzlich geworden - weil dieser Zug mit dieser Vmax den 30er Zug schnell einholt)

    Kurz zuvor schoß der Zug an einer Haltestelle (Marker) vorbei und hielt mit geöffneten Türen ca.300m hinter der Haltestelle!?


    Vieleicht kann das jemand ordentlich übersetzen und zum Helpdesk schicken. Mich würde interessieren was N3V dazu äußert?


    EDIT: Trams von ConnyXY gehen nur mit zusätzlichen Kupplungen zu verbinden (Scharfenberg). Diese sind im 3 Wagenzug 4x vorhanden. Ausgestattet, mit einer Enginespec mif Faktor28 (100kmh) + Engine=1 . Soviel zu der Möglichkeit 85kmh zu fahren.

    Nach der Änderung auf Engine=0, fährt der Zug so wie alle Anderen.

    Bleibt aber noch die Frage, warum Geschwindigkeitsmarker und Signale ignoriert wurden? Lag das nun an dem "Lokzug" mit den unterschiedlichen Motoren? - Jetzt geht es und das ist wichtig.

    Dafür gibts einen neuen Fahrfehler. Bis gestern ging es noch. An einer Einmündung kann das Programm plötzlich nicht mehr entscheiden, welcher Zug zuerst fährt. Es kommt alles zum Stehen!!!

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    Edited once, last by buderberlin ().

  • Super Beitrag!!! ......und liebe Besserungswünsche nach Berlin.


    Es ist sehr beruhigend zu wissen, dass so Trainz Vollprofis wie Du mit den gleichen Problemen zu kämpfen haben wie ich Anfänger.


    Jetzt sehe ich meine Probleme gleich viel entspannter!

    Build: 119458 ...... auf Apple MacBook Pro 16", M1 Max

  • Chris1044

    OT:

    Nicht falsch verstehen! - Das ist nur ein Verlegenheitslachen....

    Apropos Fahrleitung: Mein Beitrag

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

  • Neues Problem!

    Während in älteren Trainzversionen der Befehl "Gehe zu Zug" den eventuell vorhandenen Fahrer überschreibt, geht genau das nicht in TRS19. Obwohl ich alle Häckchen im Lokführersetup herausgenommen habe, werden allen Loks Fahrer zugewiesen. Dadurch geht die Rangiermap nicht, da es dort erforderlich ist, bestimmte Rangierloks für den Fahrerwechsel freizulassen. Alle programmierten Züge haben eine manuelle Fahrerzuordnung mit entsprechender Programmierung.

    Mit welchem KI-Befehl könnte ich die Rangierloks ausstatten, um den Fahrer automatisch aus der Lok zu nehmen?

    Es ist kaum möglich in den ersten 5 Minuten allen 11 Rangierloks manuell die Fahrer zu entfernen. Die Standorte sind über die gesamte Großmap verteilt....

    Der prinzipielle Ablauf: Ein Güterzug fährt in einen Übergabebahnhof, Zuglok spannt ab und fährt in Warteposition. Fahrerwechsel zur jeweiligen Rangierlok, die die Be- und Entladevorgänge des Zuges macht, anschließend Rückübergabe an die Zuglok mit Weiterfahrt über die programmierte Strecke.

    (Screenshots dieser Map (noch TS2010) existieren bereits im Thread "Deutsche Trainz Screenshots" z.B 37909-unnamed-20210411-0006-jpg

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    Edited once, last by buderberlin ().

  • Zwar habe ich aktuell nur Trainz+ am Laufen, aber soweit ich mich noch daran erinnern kann, hatte ich nie große Probleme mit SP5 bei Befehlen wie "Gehe zu Zug" oder die "manuelle" Eintragung der Fahrer gehabt. (Würde ungern noch den TRS2019 mit meiner Datenbank laufen lassen, da diese bereits von Trainz+ genutzt wird, weshalb ich die Probleme gerade nicht überprüfen kann, da meine Datenbank zu groß ist für eine Weitere)

    Lediglich waren die "Interlocking Tower" widerspenstig und haben nur teilweise auf der Legacy of the Burlington Northern 2 (Trainz Store Version) funktioniert.


    Ob es unter Trainz+ genauso ist, kann ich erst am Wochenende überprüfen.

    Wer braucht den Drogen, wenn es Trainz gibt?

  • Ob es unter Trainz+ genauso ist, kann ich erst am Wochenende überprüfen.

    Du kannst mir schon glauben, das es in TRS19 SP5 so ist. Bevor ich sowas schreibe habe ich alle möglichen Varianten probiert. Hier jedoch keine Lösung gefunden. Es ergab sich auf dieser Map noch ein weiteres Problem, ähnlicher Ursache. Es fahren Lokbespannte Wendezüge mit Steuerwagen. Diese Zugloks sind ebenfals programmiert, weil sie ihren Zug aus dem Abstellbereich im Bahnhof bereitstellen bzw den Zug erst mal holen (ankuppeln). Das Programm ist so blöd, dem Steuerwagen auch noch einen 2.Fahrer zuzuordnen, was im Endeffekt bedeutet, daß dieser Zug am jeweiligen Endpunkt nicht den Fahrtrichtungswechsel vornehmen kann. Mit 2 Fahrern im Zug funktioniert es nicht. In früheren Trainzversionen wäre das gar nicht möglich gewesen, eine Lok mit Ankuppelbefehl an einen Zug mit bereits vorhandener Lok anzukuppeln.

    Auch hier muß ich manuell alle 2.Fahrer der Steuerwagen nach dem Sessionstart herausnehmen, damit die Fahraufgabe funktioniert.

    Noch bescheuerter gehts nicht. TRS19 ist die unangefochtene Krönung von technischem Schwachsinn. (Blutdruck=220 :winking_face: )

    -Übrigens ist der eigentlich behobene Fehler, das Trackobjekte (z.B. Signale) statt am Gleis auf einen naheliegenden Spline (z.B. Fahrdraht) überspringen können, wieder da. Eine bestimmte Fahrschaltung funktionierte nicht, weil das Signal nicht dem Gleis angehörte- TRS19 läßt keinen Fehler aus, den es jemals gegeben hat. - Für zukünftige Trainzversionen könnte man eine Geruchsfunktion einfuhren. Wenn schon nichts mehr fährt, riecht es dann wenigstens nach Bahn.-

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), T:ane SP4 (105766) , TS12 (61383) , TS2010 SP4+PTP2 Addon (49933) , PTP2 (44663) , TS2009 (39176) , TRS2007 (3489) , PTP (2941) , TRS2004 (2388) , Trainz 1.1 deutsch

    Edited once, last by buderberlin ().

  • Das mit mehreren "Driver"n kann ich bestätigen, wurde auch an N3V weitergeleitet. Insbesondere bei Zügen mit mehreren Lok's ist das lästig.
    TRS19 SP5 und TRS22 haben den selben Bug trotz

    Grüße

    Jürgen aka Joth

    (Ex-Neuköllner)


    ''Ich habe große Achtung vor der Menschenkenntnis meines Hundes, er ist schneller und gründlicher als ich.''

    Fürst Bismarck