aktuelles Service- Pack

  • Sumpfwiese

    Was passiert eigentlich, wenn man eine angefangene Map mit eigener Region aus dem alten TRS2019 in eine neue Version importiert?

    Wird dann alles, was noch als Grid liegt, auch zur (vermutlich nicht gerade performancefreundlichen) "Sumpfwiese"?

    Klar könnte ich mir die Frage irgendwann selbst beantworten, im Moment habe ich ehrlichgesagt aber noch keine Ambitionen auf solch Experimente.

    Daher mal theoretisch gefragt..

    TRS2019 Build 114800

    V100, Umbauwagen, Silberlinge: Wohlbehagen, das Maß der Dinge..

    • Official Post

    Wieso sollte die Sumpfwiese performanceunfreundlicher sein als das Grid?


    Bestehende Baseboards werden wohl nicht aktualisiert, die Einstellung gilt wohl nur für neue Baseboards.


    Das Grid ist im Grunde auch nur eine Bodentextur, die bisher eben standardmäßig für neue Baseboards genommen wurde.

  • Auf der DLS gibt es unter anderem die folgenden Regionen, die eine Gittertextur verwenden:

    <kuid:45176:100490> Australia with TRS19 Grid

    <kuid:45176:100362> United Kingdom with TRS19 Grid

    <kuid:45176:100437> United States with TRS19 Grid

    <kuid:45176:100481> France with TRS19 Grid

    <kuid:45176:100488> Germany with TRS19 Grid

    <kuid:45176:100499> Switzerland with TRS19 Grid

    Alle sind Trainz-Build 4.8.


    Peter

  • Wieso sollte die Sumpfwiese performanceunfreundlicher sein als das Grid?

    Nach meinem Verständnis braucht´s dafür eine weitaus höher auflösende Textur, sowas verwende ich eigentlich nur Trackside bzw. als "Topping".

    Oder haben Bodentexturen auch so etwas wie ein LOD? :thinking_face:


    Auf der DLS gibt es unter anderem die folgenden Regionen, die eine Gittertextur verwenden:

    Da stellt sich mir gleich die nächste Frage: Wie wird das eigentlich definiert, oder anders:

    Kann man auch herkömmliche Regionen so umschreiben, das sie keine Sumpfwiese produzieren?

    TRS2019 Build 114800

    V100, Umbauwagen, Silberlinge: Wohlbehagen, das Maß der Dinge..

    • Official Post

    also wenn man die von p-denehrt empfohlene Region <kuid:45176:100488> Germany with TRS19 Grid benutzt ,hat man dann auch den Strassenverkehr dieser Region?

    Ja, u.A. deswegen wurden ja verschiedene Grid-Regionen erstellt.

    Nach meinem Verständnis braucht´s dafür eine weitaus höher auflösende Textur, sowas verwende ich eigentlich nur Trackside bzw. als "Topping".

    Oder haben Bodentexturen auch so etwas wie ein LOD? :thinking_face:

    Bodentexturen werden ja nur einmal in den Speicher geladen, ob du sie am Gleis verwendest oder auch im Hintergrund, das ist ja egal.


    Schau dir mal das Grid-Asset an. Mir fehlt jetzt die Zeit, die .texture-Dateien zu konvertieren um die Abmessungen zu sehen, aber alleine die Dateigrößen (6MB pro .texture) lassen drauf schließen, dass es ebenfalls hochaufgelöste Texturen sind.

  • Da stellt sich mir gleich die nächste Frage: Wie wird das eigentlich definiert, oder anders:

    Kann man auch herkömmliche Regionen so umschreiben, das sie keine Sumpfwiese produzieren?

    Wenn ich das richtig sehe ist nur ein Eintrag in der Region - Config.txt nötig für den Grid Zusatz:


    default-texture <kuid:-25:1180>


    Dieser Eintrag fehlt jeden falls bei den alten Regionen.


    MfG Torsten


    P.S. Die trainz-build muss auf trainz-build 4.8 gesetzt werden , sonst gibt es eine Fehlermeldung.

  • Hallo verehrte Trainzer!
    Ich habe etwas experimentiert und habe dabei festgestellt, das es sich hier um eine Region handelt (Deutschland TRS 19 Grid). Eine provisorisch verlegte Straße lässt auch Autoverkehr zu. In diesem Falle, sind es nur PKW. In der Nachtsimulation sind alle Fahrzeuge mit entsprechender Beleuchtung versehen. Die dazu gehörige confix gibt Aufschluss über die Anzahl der Fahrzeuge. Es ist gut möglich das jemand, der es versteht, die confix mit Lkw und Busse erweitert.
    Die Möglichkeit eine andere Region zu wählen, ist im Editormodus möglich. Nur nach der Erweiterung der Bodenlatte erscheint die Sumpfwiese. Reziprok heißt das, wer die Wahl hat die Qual. Bisher habe ich die Region VTL Region 2017 verwendet, da eine gute Mischung von unterschiedlichen Fahrzeugen auf den Straßen unterwegs ist.
    Gegenwärtig ist an einem Neubau nicht zu denken, da ich Zähneknirschend damit konfrontiert bin, Bahnsteige, sowie Gebäude auszuwechseln und bei Güterzügen die Geisterwagen gegen noch verfügbare Wagen auswechseln kann. Immerhin gibt es einen Lichtblick, da ein netter Mensch den VT 18.16 und die Altenberger wieder zu Leben erweckt hat.
    Gruß Klaus

  • Ich finde, daß Servicepack 5 in TRS19, ist zu früh erschienen. Der 1.April, wäre der geeignetste Tag dafür. Alle Fehler die es jemals im KI-Betrieb gegeben hat, sind hier vereint und treten minütlich in Erscheinung. Hier mal ein lustiges Beispiel:

    Im TRS2007 gab es unter bestimmten Vorraussetzungen einen KI-Fehler, der einen Zug völlig unsteuerbar mit Schrittgeschwindigkeit fahren ließ. In den meisten Fällen war diese Session damit beendet.

    Jetzt, brandneu im TRS19:

    Hamster kommt etwas lädiert aus einem Portal und bleibt unsteuerbar. Leider hatte ich keine Möglichkeit, gegen einen Prellbock zu fahren, um eine Entgleisung zu erzwingen. Ich habe den Zug dann aufs Gegengleis gebracht, um ihn mit einem anderen Zug aufzuhalten. Beim Aufprall hoben sich die Pantos, aber mehr auch nicht. Mühevoll gelang es mir, manuell auf ein unprogrammiertes Gleis zu gelangen. Dort wollte ich den kaputten Zug abstellen und den Hilfszug wieder in den Programmbetrieb bringen. Ging auch nicht, weil der Hamster dann von allein wieder losrollt. Ich mußte dieses Gespann dann dort so stehen lassen. Es ging auch mit dem Hilfszug nichts zu löschen.

    Das ganze spielte sich am Rand der EQB zwischen Trier und Ehrang ab. Auf der Map sind 8.00 Uhr 120 Züge gestartet. 13.30 Uhr waren es noch 70 Züge. 50 Züge mußte ich nach schweren Fahrfehlern löschen. Wenn wir den Realismus-Gedanken weglassen, ist das Programm doch eine tolle Spielidee des Herstellers.....

    Todo-Liste: "Baue hinter jedes Portal ein Sandgleis, um kaputte Züge aussortieren zu können"

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), TRS19 SP? (98592), T:ane SP4 (105766), TS12 (61383), TS2010 SP4+PTP2 Addon (44663), TS2009 (39176), TRS2007 (3489), PTP (2941), TRS2004 (2388), Trainz 1.1 deutsch

    Edited 3 times, last by buderberlin ().

  • Nach dem Patch von TRS19 heute auf Build:117009 hat sich wohl einiges geändert.

    Keine unverständlichen Menü-Einträge mehr.

    Images

    Betriebssystem: Windows 10 Pro 64Bit

    Intel(R) Core(TM)i7-2600 CPU @ 2x3.40GHz ; Mainboard: MSI MS-7728 ; Arbeitsspeicher16GB ; Grafikkarte: NVIDIA GeForce GTX 1060 6GB

    TS12 Build:61383;TMR2017 Build:85470;T:ANE SP4-Build:105766;TRS2019(PE)SP5 Build117009

  • Um mal an meinem vorherigen Post #29 anzuschließen, auch im Hotfix Build 117009, ändert sich im KI-Betrieb nichts.

    Portale funktionieren eine gewisse Zeit, dann kommt ein Punkt, an dem Züge nur noch unvollständig wieder herauskommen. Ich habe es mal weiter laufen lassen. Nach ca. 4 Stunden verschwinden die Portalzüge für immer. Was wesentlich schlimmer ist, fast jeder 2.Zug läßt Gleismarkierungen aus und blockiert in seiner Irrfahrt irgendwann (wenn er seinen Fehler bemerkt) die restlichen noch richtig fahrenden Programmierungen, weil er ständig Weichen blockiert, so das Alles zum Erliegen kommt.

    Überspitzt ausgedrückt: Jedem Zug seinen eigenen Ring, am besten ohne Weichen und Signale.....

    Ich würde dem Hersteller gerne mal die Frage stellen, welcher Zusammenhang zwischen der verbesserten Grafik und dem Zerstören des ursprünglich mal besser funktionierenden Fahrbetriebs besteht.

    Mit freundlichen Grüssen Frank - Sincerely Frank - Sinceramente Franco - Z poważaniem Frank - З повагою Франк - Tisztelettel Frank - S pozdravem Frank - Met vriendelijke groet Frank - Med venlig hilsen Frank - Cordialement Franck


    Wenn jemand Probleme braucht, ich habe immer welche übrig....


    TRS19 SP5 (117009), TRS19 SP? (98592), T:ane SP4 (105766), TS12 (61383), TS2010 SP4+PTP2 Addon (44663), TS2009 (39176), TRS2007 (3489), PTP (2941), TRS2004 (2388), Trainz 1.1 deutsch

  • Auf der Map sind 8.00 Uhr 120 Züge gestartet. 13.30 Uhr waren es noch 70 Züge. 50 Züge mußte ich nach schweren Fahrfehlern löschen. Wenn wir den Realismus-Gedanken weglassen, ist das Programm doch eine tolle Spielidee des Herstellers.....

    Sieh es mal Positiv:

    du kannst jetzt Online - Wetten annehmen.

    Welcher Zug fährt bis zum Ende durch :question_mark:

    Damit kriegst wenigstens eine Entschädigung für den Testaufwand :rolling_on_the_floor_laughing:

    Grüße

    Jürgen aka Joth

    (Ex-Neuköllner)


    ''Ich habe große Achtung vor der Menschenkenntnis meines Hundes, er ist schneller und gründlicher als ich.''

    Fürst Bismarck

  • Hallo liebe Community,

    ich hoffe es passt in diesen Thread, ich hab den letzten Patch für Trainz Platinum Edition 2019 installiert Version116678 und nun sind einige Menüpunkte kryptisch. Z.b. $ts17menu_button... Gibt es dazu evtl. eine Problemlösung? Ich habe schon dazu gegooglet und nix gefunden.

    Vielen Dank.

    Hi Stephan

    Dieses Problem haben die sogar zur beta von TRS22 mit übernommen.

  • Hallo, ich war gestern auf Facebook. Schaue dort auch viel von den Tschechen an. bei denen scheint ja diese Problem auch zu herrschen.

    Dort hatte einer ein Screenshot reingestellt von TRS2019 mit der build-Nummer 116708. Dort besteht der Fehler nicht mehr. Da ich TRS2019

    auch installiert habe, bin ich auch gleich ins Programm, habe die Update`s gemacht und war auch enttäuscht. Build-Nr. 116768 und dann nichts

    mehr. Also heißt es abwarten. Was bei den Tschechen kommt, sollte doch bei uns auch kommen.

  • Stell mal die Sprache auf ENGLISH

    Meinst Du mich? :thinking_face: Wie Du sehen solltest ist der Launcher auf Englisch eingestellt.

    Hallo Zusammen, ich habe auch folgendes Problem unter TRS19 Sp5 mit und ohne Patch:

    ...

    Definiert

    Erst einmal herzlich willkommen hier im Forum.


    Meine Bitte an Dich. Mach bitte zum Thema einen

    eigenen Thread auf und lösche Dein Posting hier.


    Meine Begründung:

    Wenn es ein echtes Problem mit den Skripten ist,

    könnten andere auch daran interessiert sein.


    Ich denke, Peter Dehnert p-dehnert wird Dir

    sehr zeitnah auf Deine Fragen antworten.


    Wenn es ein Problem, hervorgerufen durch eine

    Veränderung der config.txt, wäre es auch anders

    besser aufgehoben.


    Ich möchte Dich damit nicht ärgern. Ich möchte

    gern die Themen etwas auseinander gehalten

    sehen.


    Vielen Dank

    Udo

    Hier entsteht eine neue Signatur.

    Der Betrieb läuft trotzdem weiter.

    • Official Post

    Um mal an meinem vorherigen Post #29 anzuschließen, auch im Hotfix Build 117009, ändert sich im KI-Betrieb nichts.

    Portale funktionieren eine gewisse Zeit, dann kommt ein Punkt, an dem Züge nur noch unvollständig wieder herauskommen. Ich habe es mal weiter laufen lassen. Nach ca. 4 Stunden verschwinden die Portalzüge für immer. Was wesentlich schlimmer ist, fast jeder 2.Zug läßt Gleismarkierungen aus und blockiert in seiner Irrfahrt irgendwann (wenn er seinen Fehler bemerkt) die restlichen noch richtig fahrenden Programmierungen, weil er ständig Weichen blockiert, so das Alles zum Erliegen kommt.

    Hatte nach den letzten 2 SP die Lust verloren mich mit AI Fahrbetrieb weiter zu beschäftigen. Zu vielfältig waren (sind [auch mit SP5]) die Probleme. Seit dem SP2 gibt es nun diese Probleme mit den Portalen. Gestern testete ich nun mal meine Strecke im SP5 und dabei fiel mir zum ersten Mal Folgendes auf: Probleme (Portalfehlermeldungen oder Entgleisungen) kamen nur bei portalgenerierten Zügen vor, in denen Loks oder Wagen auch als "reversed" eingereiht sind. Also änderte ich meine Portalkonfiguration so ab, dass nun nur noch Wagen und Loks als "forward" eingereiht sind. Das hat natürlich den Nachteil, dass nun Triebzüge nicht mehr generiert werden können, da bei den meisten ein Kopf als reversed eingereiht werden muss. Und auch Doppeltraktionen lassen sich so nun nur noch etwas langweiliger gestalten. Aber es funktionierte dann mit allen anderen Zügen!


    Dann ließ ich die Strecke mal länger laufen. Als ich nach vier Stunden mal wieder schaute: keine Entgleisungen und keine Portalfehlermeldungen! Jedoch lief die Strecke wie ein Haufen Knete. Der KI Betrieb war fast völlig eingeschlafen und wenn ich über die Map 'flog' aktualisierten sich sämtliche Splines (Gleise und Scenery) nur im Schneckentempo. Da liegt also noch was im Argen.


    Das Gleiche tat ich dann mit der selben Strecke in meiner SP2 Installation, wo es die selben Probleme mit Portalfehlermeldungen und Entgleisungen gab. Mit den geänderten Wagenrichtungen in der Portalkonfiguration läuft diese Strecke mit durchschnittlich 40 Zügen nun seit gestern 22:00 wie ein Uhrwerk.


    cheers

    Christian