Posts by TrainzMax

    Den Installationsordner kannst du bei beim Setup (oder bei Steam) im Vorfeld wählen.

    Im Startfenster von Trainz kannst du dann den Pfad festlegen, wo Trainz deine lokalen Inhalte speichern soll (entspricht dem "trs19"-Ordner). Da kannst du das Verzeichnis ja auch auf einen anderen Datenträger auslagern.

    Hallo,


    mir sind nur Berlin Hbf und Berlin Potsdamer Platz bekannt, aus den PTP2 Add-Ons 3 oder 13. Freeware sind die aber ja leider nicht. Wenn es nur kleine Bahnhöfe sein sollen (z.B. U- oder S-Bahn), dann such dir mal auf der DLS die Bahnhöfe vom "HVV Projekt" raus. Da ist bestimmt dann was dabei.


    Grüße

    Max

    Hallo,


    idealerweise sicherst du deine lokalen Trainz-Ordner auf ein anderes Laufwerk, z.B. eine externe Festplatte. Wenn du neben dem Windows-Laufwerk in deinem PC noch weitere Datenträger hast, kannst du Dateien auch dahin kopieren, du musst du aufpassen dass du bei der Neuinstallation nicht versehentlich den Datenträger formatierst.


    Sichern solltest du:

    - Hauptinstallationsordner von TRS 2019 (Siehst du z.B. in Steam)

    - TRS2019-Ordner aus den lokalen Benutzerdateien


    So kommst du zum benutzerlokalen Ordner (wenn du an dem Pfad nicht selber was verändert hast):

    1. Windows-Explorer starten und in die Adresszeile %appdata% eingeben -> du landest im Ordner "Roaming".

    2. Dort einen Ordner zurück gehen, und dann in den Ordner Local

    3. In den Ordner N3V Games gehen

    4. Den Ordner trs19 ist der Ordner den du sichern solltest.


    Das kann mitunter einige Zeit in Anspruch nehmen, das ist völlig normal.


    Auf dem neu installierten Windows gehst du nun wieder in den Local-Ordner und erstellst einen Ordner namens "N3V Games"

    dort hinein kopierst du jetzt dein Benutzerverzeichnis-Backup "trs19".


    Ich hoffe ich habe nichts vergessen, vielleicht wartest du nochmal etwas, falls jemand noch "Stop!" sagt.


    Viel Erfolg.

    Hallo,


    ich bin gerade nicht mehr sicher welches Symbol das ist - entweder bedeutet es, dass Abhängigkeiten fehlen oder, dass welche fehlerhaft sind. Mach mal einen Rechtsklick auf eine Aufgabe, und wähle "Abhängigkeiten anzeigen" oder so ähnlich aus.


    Dann bekommst du ein Fenster in dem alle Objekte aufgelistet werden, die die Aufgabe braucht. Wenn du da rote Symbole siehst, liegt es Nahe dass das Rollmaterial fehler verursacht - das ist bekannt bei einigen Fahrzeugen in PTP2.


    Wenn dem so ist, filtere im Content Manager nach fehlerhaften Objekten. Markiere diese alle, und öffne alle Per Rechtsklick -> Bearbeiten -> Zum Bearbeiten öffnen. Wenn das fertig ist, kannst du sie per Strg+A und dann Strg+M neu einbinden. Dann sollte das klappen.


    Wenn Abhängigkeiten komplett fehlen, gehe in deinen Instalaltionsordner von PTP2, dann in den Unterordner "bin" und starte die .bat/.cmd-Datei die sinngemäß irgendwas heißt von wegen "ADD4 install" oder so ähnlich als Administrator. Dann werden die Dateien nochmal installiert.


    Ich hoffe das hilft Dir.


    Grüße

    Max

    Probier mal aus, das ganze in einen Windows-Editor zu kopieren - oder sogar einfach nur in das Windows-Suchfeld. Wenn das selbst da nicht ankommt, wird es wohl, wie Mika schon sagt, ein Problem mit Trainz sein. Die Situation hatte ich auch schon öfter mal.

    Hallo zusammen,


    seit meinem Wechsel auf TRS 2019 fällt mir auf, dass ich es nie richtig hin bekomme, einige Objekte um genau 180.0 Grad zu drehen. Bei einem 350 Meter langen Objekt, das parallel zu einem anderen liegen soll, fallen diese 0,1 Grad differenz zu 179,9° schon sehr auf, so dass man damit nicht schön bauen kann.


    Gibt es da einen Kniff oder stell ich mich einfach zu dusselig an? Wie kriege ich sowas präzise gedreht? Was mal geil wäre, wenn man den °-Wert manuell eintippen könnte...


    Beste Grüße, Max


    Edit: Selbst mit Mausempfindlichkeit in Windows geht es nicht. Nach 179,9 Grad kommt direkt 180,3 Grad.

    Hallo zusammen,


    auch ich habe jetzt den Wechsel auf TRS 2019 gewagt und es bisher nicht bereut! An einem Punkt hake ich jetzt aber fest:


    Damals in PTP2 bzw. Trainz 2010 gab es eine Regel in den Aufgaben namens Start-Optionen. In dieser hatte ich die Möglichkeit, die Aufgaben-Uhrzeit, den Fahrermodus und noch ein paar andere Einstellungen festzulegen. Ich habe einige Assets aus der alten PTP2-Datenbank in mein TRS 2019 importiert, so dass ich nicht genau sagen kann, ob die Regel "Start-Optionen" schon zum TRS 2019-Inventar gehört oder ob ich jetzt diese alte Regel aus PTP2 mitgenommen habe.


    Jedenfalls habe ich diese Regel nun in meine Session eingebunden und konfiguriert - jedoch "greift" sie nicht. Egal was ich dort einstelle, die Aufgabe beginnt immer um 10:00 Uhr im Trafomodus.


    Was ist der richtige Weg, das ganze einzustellen? Im Trainz Online Wiki bin ich leider nicht fündig geworden. Gehört die Regel auch zu TRS 2019, oder hab ich einfach eine alte Regel mit importiert? Das würde erklären warum sie nicht funktioniert. Und falls dem so ist, wie ist der richtige Weg im neuen Trainz, die Uhrzeit und den Fahrermodus von Trafo auf Führerstand zu ändern?


    Danke im vorraus und Gruß

    Max

    Vielen Dank! Ich habe meine Assets jetzt in Trainz 12 übertragen können. Danke für den Tipp.

    Bis auf ein paar Objekte funktioniert das auch recht gut, nur die PTP2 Bahnsteige sind irgendwie nicht funktionsfähig. Liegt aber wahrscheinlich eher daran, dass sie für ältere Builds gemacht wurden.

    Hi,


    das das auch so "einfach" geht wusste ich gar nicht. Das ist ja um so besser!


    In meinem \UserData\local\ Ordner sind ganz viele Ordner mit "hash-XX". Dadrin sind Ordner die nach den KUIDs benannt sind.

    Welche Ordner muss ich denn importieren? Die ganzen Ordner namens "kuid xxxxxx xxxxxx"?


    Grüße, Max

    Hallo zusammen,


    erstmal natürlich nochmal vielen Dank für die Antworten. Ich habe jetzt erstmal weitergespielt aber das Problem ist bisher nicht gelöst. Ich habe mittlerweile 19 Iterationen meiner Strecke, einfach weil der Fehler ständig neu auftritt. Da ich um eine komplette Neuinstallation wohl nicht mehr herumkommen werde, anbei ein paar Fragen.


    Ausgangssituation ist, dass ich viel Content von der DLS, aber um so mehr Content auch so von Webseiten installiert habe, und ich diese Abhängigkeiten nicht verlieren möchte. Darüber hinaus ist auch ein Trainz 2009 in meinem Trainz 2010 eingebunden.


    Da ich nicht mehr alle CDPs besitze möchte ich eigentlich meine Datenbank als CDP haben. Diese sind soweit ich weiß aber ja auch in der maximalen Größe limitiert, sodass ich nicht einfach alles in eine Datei packen kann. Da kam mir dann der Gedanke des TrainzUtils auf, mit dem ich ja per CLI bzw. Script einzelne Objekte als CDP exportieren kann. Dort würde ich dann einfach jedes Objekt einzeln exportieren und mit %RANDOM% einfach irgendeinen Namen geben. Wie die Dinger heißen ist mir erstmal egal, hauptsache sie sind alle da.


    Kann ich mit dem TrainzUtil mit einer forEach-Schleife durch die Datenbank durchloopen? Wenn soll das ganze ja schon komplett automatisiert sein und er soll nach und nach alle vorhandenen Objekte abspeichern. Ausschließen würde ich per Filter die Daten von vizzart aus PTP2, die installiere ich dann manuell nach.


    Zusätzlich würde ich das ganze dann mit einem Umzug zu Trainz 12 verknüpfen und alle meine Daten plus die Base.ja Dateien von PTP2 und Trainz 2009 dort installieren.


    Ist mein Vorhaben prinzipiell umsetzbar? Und wenn ja, wie kriege ich das mit der forEach Schleife am besten hin? (Oder gibt es sogar eine bessere Methode...?)


    Beste Grüße

    Max

    Hallo alle zusammen,


    ich habe ein Problem mit meinem Trainz (2010). Ständig weißt mich mein Spiel darauf hin, dass es nicht mehr in der Datenbank speichern kann und dass ich das im CMP selber nachholen müsse. (Siehe Screenshot im Anhang)

    Ich habe bereits versucht, den Anwendungen Trainz.exe (Sowohl Launcher als auch das eigentliche Spiel im \bin-Verzeichnis, ContentManager.exe, TrainzUtil.exe und TADDaemon.exe in Windows manuell in der Eigenschaften-Kartei Administatorrechte zu geben. Die Sicherheitsabfragen habe ich alle mit Ja bestätigt, das Problem bleibt trotzdem bei.


    Hat jemand eine Idee, wie ich das Problem lösen kann? Ich würde ungerne alles neu installieren, da ich mittlerweile sehr viel Content im Spiel habe, der Aufwand der Neuinstallation wäre da wirklich extrem hoch.


    Vielen Dank im vorraus und ein schönes Wochenende!

    Max