Trainz 2019 lädt massiv nach und ruckelt

  • Liebe Commnuity,


    wie auf dem Discord schon öfter erwähnt, läuft mein Trainz 2019 nicht wirklich. Ständiges und erneutes Nachladen von Texturen und sind normal.


    Zur besseren Erläuterung habe euch mal ein Video verlinkt. Mit dem ihr euch selbst ein Bild machen könnt.


    https://www.youtube.com/watch?v=462b30g1FDQ&t=22s


    Mein Notebook hat folgende Komponenten.


    - 8 GB Arbeitsspeicher auf einem Riegel


    - Einer kleinen SSD und einer HDD auf der Trainz ist.


    - I7 7700HQ bis 3,80 GHz


    - GTX 1060 Max Q 6 Gb


    Normalerweise müsste der Notebook, Trainz 2019 locker packen. Aber es läuft gerade so auf mittleren Einstellungen (siehe Bild)


    Danke für eure Hilfe.


    Grüße


    Railworker

  • Hi @ all,


    also angesichts der Hardware sollte das schon flüssiger laufen.

    Mein Setup sieht wie folgt aus:

    CPU: AMD Ryzen 5 2600 (6c/12t)

    GPU: Asus GTX 1050Ti 4 Gb Vram

    RAM 16 Gb DDR3 3200Mhz

    Trainz liegt bei mir auf einer SSD

    Und das sind meine Einstellungen in TRS19:


    Wobei ich aber auch ganz klar sagen muss. In dem Video sieht man den Krachtinger Hafen, da habe ich auch meist so 10 bis 15 FPS. Das hängt aber auch immer ein Stück weit von der Blickrichtung ab.

    Wie sieht es denn mit deinen Allgemein/General TRS19 Einstellungen aus? Versuche doch mal Vsync auf Full zustellen, das hat in meinem Fall eine Menge gebracht.


    Zum Schluss: Wie verhält sich Trainz bei dir auf anderen Karten, bspw. auf den Build-in Strecken?

    Grüße,

    Marcel

  • Der Vsync ist auf Full und ich spiele in Full HD.


    Bei anderen Karten ist das ähnlich. Nach dem Ladebildschirm ist erstmal nur die Bodentextur in schwächster Auflösung zusehen, danach lädt alles nach (Häuser, Gleise, Züge)


    Es kann auch mal vorkommen das ich ohne Gleise durch die Landschaft fahr, da er zu lange zum Nachladen braucht, dabei fährt sich Trainz flüssig. Nur die Objekte erscheinen verspätet.


    Das alte T:ANE läuft übrigens mit allen Regler auf Anschlag bestens. Der Trainz 2019 nicht

  • Und das sind meine Einstellungen in TRS19:

    Auflösung von Schatten in 4096 ist absolut OP, der Unterschied zu 2048 ist dabei nicht so groß und es werden Resourcen frei für andere Spielereien.


    Railworker Stelle mal die Detail Update Rate etwas höher, da ist schon die erste Bremse. Wenn du ihm sagst er soll langsam nachladen, dann macht er es auch. Dann stelle das Antialising mal etwas runter, auf 4x. Anschließend schaust du InGame wie hoch die Baumdetails sind, alles andere als "low" ist mit den verfügbaren Bäumen und Büschen unmöglich. Wer zB St_rmm-Bäume verwendet begeht eine grobe Fahrlässigkeit, wenn er diese flächendeckend nutzt (hier wurde vom Autor nichts getan um ein wenig zu optimieren).


    Und ganz wichtig: Auf einem Notebook aktiviert Windows ein erheblich aufwändigeres Energiemanagement. Da sollte man zuerst prüfen, ob etwas umgestellt wird. Das Notebook wenn möglich im Netzbetrieb laufen lassen (gute Notebooks schalten den Akku ab, wenn sie im Netzbetrieb sind, sodass diesem kein Schaden droht), die Energieoptionen so einstellen, dass alles mit maximal möglichem Strom versorgt werden kann. Windows bietet teilweise unter Akkubetrieb nicht einmal an, volle Leistung zu geben (so zB auf meinem Asus-Notebook).

    Ich schrieb neulich im Chat, dass ein Notebook eben kein 800 Watt Netzteil hat, was volle Power geben kann. Das sollte man berücksichtigen, wenn man argumentiert dass die Hardware doch viele können soll. Sie kann eben nur solange, wie sie genug Energie für ihre Aufgaben bekommt. Das fängt schon bei der Festplatte an.

  • callavsg


    Der Notebook wird sowieso nie im Akkubetrieb genutzt. Er hängt immer am Netz und an einem externen Bildschirm. Der Grund hierfür ist denkbar einfach ich befinde mich aus Beruflichen Gründen, während der Woche immer woanders wie am Wochenende. Ein Tower PC wäre nicht so flexibel.


    Natürlich schwebt mir auch die Überlegung im Raum evtl fürs Wochenende, den Tower PC Fit zumachen.

  • ShadowRock

    Naja, wenn man es kann, dann gehts ja, war auch eher allgemein gemeint und nicht auf deine Einstellungen spezifisch gemünzt.


    Railworker

    Das klingt doch schonmal gut, hast du mal in den Energieoptionen geschaut, ob da eventuell was nicht so eingestellt ist, wie es sollte?

    Auf meinem Notebook läuft Trainz auch nicht gut, habe aber auch keinen i7 und Co. Ich würde fast darauf tippen, dass es bei dir an der

    Energieversorgung liegt, zu mind. sollte Trainz flüssig laufen, wenn man die Einstellungen niedrig hält. Da du eine SSD hast, schließe ich die Übertragungsgeschwindigkeit der Festplatte an sich mal aus, diese sollte gut rennen, sofern sie genug Strom hat.

    Was vielleicht interessant wäre, ob nebenher etwas mitläuft, was ordentlich zieht. Bei mir hatte ich zB das Problem, dass der Diagnoseübermittlungsdienst 1GB RAM und die CPU für sich vereinnahmt hatte. Vielleicht ist da etwas ähnliches bei dir?

  • ShadowRock

    Energieversorgung liegt, zu mind. sollte Trainz flüssig laufen, wenn man die Einstellungen niedrig hält. Da du eine SSD hast, schließe ich die Übertragungsgeschwindigkeit der Festplatte an sich mal aus, diese sollte gut rennen, sofern sie genug Strom hat.

    Was vielleicht interessant wäre, ob nebenher etwas mitläuft, was ordentlich zieht. Bei mir hatte ich zB das Problem, dass der Diagnoseübermittlungsdienst 1GB RAM und die CPU für sich vereinnahmt hatte. Vielleicht ist da etwas ähnliches bei dir?

    Der Chrome und der Discord sind auch sehr Ram Hungrig bei mir ansonsten läuft im Hintergrund nix, außer der Norton aber der ist sparsam. Wenn dann noch Trainz läuft, habe ich gute 80 % Auslastung am RAM. Zum Thema SSD muss ich sagen das diese knappe 120 Gb groß ist und eine PCIE SSD ist auf der nur das System liegt. Trainz sowie alle anderen Programm lagern aber auf einer HDD.